May 23, 2019, 02:42:20 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Got a noob question already  (Read 2241 times)
Matboyslim
Guest
« on: March 29, 2015, 08:47:51 PM »

Hi,  I picked up my new X10 500 yesterday. I want to mount an iPhone to the handlebars. There is a black plastic thing in the middle of the handlebars with A Piaggio logo in the middle. If I manage to take that plastic off, will there be a mount underneath ready to screw a mount onto ? I have tried to take that plastic cover off, but I feel that if I pull any harder it will snap off, is there a knack to it ? Does the whole thing come off or just the Piaggio logo ?  Any advice will be very welcome. Thanks in advance.
Logged
redeye
Doctor of Scooterology
*****

Karma: 28
Offline Offline

Location: Fannin County, Georgia
Posts: 2190

Thank You
-Given: 119
-Receive: 183



Email
« Reply #1 on: March 30, 2015, 02:11:31 AM »

Perhaps a shot in the dark, as I have no experience with Piaggio products, but does this photograph show the same scooter model as yours?



If so, then the answer to your first question appears to be yes...

Logged

Years of bad habits often masquerade as 'experience'
Liamjs
Doctor of Scooterology
*****

Karma: 3
Offline Offline

Location: Los Angeles, CA
Bikes Owned: 07 Burgman 400 & 05 Burgman 650
Posts: 569

Thank You
-Given: 2
-Receive: 23



« Reply #2 on: March 30, 2015, 02:31:36 AM »

I wouldn't count on there being a mounting screw in there.  It's plastic, and unless there's a screw directly connected to the handlebars underneath, you don't want to mount anything on to it. 

A lot of riders use a brake reservoir mount. Like this set up.

To mount Garmin:
http://www.amazon.com/gp/product/B0055PH0XA/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
http://www.amazon.com/gp/product/B003CMNXIO/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
http://www.amazon.com/gp/product/B002L9LW00/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
Logged
Expat47
Administrator
Doctor of Scooterology
*****

Karma: 27
Offline Offline

Location: Athens, Greece
Bikes Owned: Kymco AK550 & '12 Piaggio X10 (sold). & '08 SYM GTS (sold)
Posts: 3531

Thank You
-Given: 129
-Receive: 161


Kymco AK550


WWW Email
« Reply #3 on: March 30, 2015, 07:19:44 AM »

Yes, the phone mount goes where the Piaggio emblem is on the handlebars. You should have gotten a mount along with your scoot. At least I got one with mine back in '12.

I've checked my manuals and there are no instructions on how to put the thing onto the X10. The only references are that there is there should have been one under the seat when you bought it and you need to talk to the service department to put it on.

I just watched them pull the emblem off mine a month ago but didn't pay much attention. There were no special tools used and that's all I've got. Sorry

Oh.. yea... congrats on the new ride.

Logged

__
Don
Expat47
Administrator
Doctor of Scooterology
*****

Karma: 27
Offline Offline

Location: Athens, Greece
Bikes Owned: Kymco AK550 & '12 Piaggio X10 (sold). & '08 SYM GTS (sold)
Posts: 3531

Thank You
-Given: 129
-Receive: 161


Kymco AK550


WWW Email
« Reply #4 on: March 30, 2015, 07:30:03 AM »

Here's a link to an app for the X10
http://www.piaggio.si/static/_u/files/2013/01/85a2510b8c418897314f372c087fec95.pdf

For the life of me I can't find anything on how to put that mount on the scoot!

I am totally useless before I've finished my coffee!!!! I went out to the shed and got my mount, took a picture, and scanned in the instructions. Here's the PDF that should answer all your questions.
http://www.imagesby.me/x10/x10_phone_mount.pdf

But... like I said... all this SHOULD have been under your seat when you got your scoot.
Logged
redeye
Doctor of Scooterology
*****

Karma: 28
Offline Offline

Location: Fannin County, Georgia
Posts: 2190

Thank You
-Given: 119
-Receive: 183



Email
« Reply #5 on: March 30, 2015, 01:54:23 PM »

For the life of me I can't find anything on how to put that mount on the scoot!

I searched for a while, looking for an exploded diagram or instructions. No luck at all. A screen shot of your hardware scan follows...



Matboyslim, congratulations on your new ride and best wishes on the installation.
Logged
Maggie
Administrator
Doctor of Scooterology
*****

Karma: 168
Offline Offline

Location: St. Louis
Bikes Owned: The Fastest Ever Bet & Win 310cc ~ Tsunami 650cc ~ 09 TMax ~ 09 DN-01 ~ 17 Sypder RT-Limited
Posts: 15512

Thank You
-Given: 324
-Receive: 801


Let's Ride!!!!!!


« Reply #6 on: March 30, 2015, 03:12:22 PM »

First...   to the forum.


If the logo cover has no push pins underneath bottom or top, it's probably attached with good pressure to a pressure clip.   Pull gently till it pops.
Logged

It's a scooterful day in the neighborhood!
redeye
Doctor of Scooterology
*****

Karma: 28
Offline Offline

Location: Fannin County, Georgia
Posts: 2190

Thank You
-Given: 119
-Receive: 183



Email
« Reply #7 on: March 30, 2015, 03:20:12 PM »

If the logo cover has no push pins underneath bottom or top, it's probably attached with good pressure to a pressure clip.   Pull gently till it pops.

Sounds right. Expat47's scanned instructions read, "Remove the Piaggio badge from the handlebar central cover and the screws underneath. Remove the central cover."
Logged
Maggie
Administrator
Doctor of Scooterology
*****

Karma: 168
Offline Offline

Location: St. Louis
Bikes Owned: The Fastest Ever Bet & Win 310cc ~ Tsunami 650cc ~ 09 TMax ~ 09 DN-01 ~ 17 Sypder RT-Limited
Posts: 15512

Thank You
-Given: 324
-Receive: 801


Let's Ride!!!!!!


« Reply #8 on: March 30, 2015, 05:03:08 PM »

You expected me to read that!
Logged
Expat47
Administrator
Doctor of Scooterology
*****

Karma: 27
Offline Offline

Location: Athens, Greece
Bikes Owned: Kymco AK550 & '12 Piaggio X10 (sold). & '08 SYM GTS (sold)
Posts: 3531

Thank You
-Given: 129
-Receive: 161


Kymco AK550


WWW Email
« Reply #9 on: March 30, 2015, 05:39:50 PM »

Most of this looks to be intuitive once you get the emblem off. The 'missing' piece is the actual clamp/holder that one would need to purchase to fit whichever device they happen to be using.

Here's what is says:

1. Remove the Piaggio badge from the handlebar central cover and the
screws underneath. Remove the central cover.

2. Fix bracket (B) utilising the 2 screws (G) above and the 2 screws (E)
below [1]

3. Reposition the plastic cover and fix utilising the standard screws
[2A] [2B]. When using a navigation device, pullout the cable [2A]

When using a Smartphone, leave the cable under the cover [2B]
  Fixing the navigation device
  A. Insert the feed cable into the cover (C)
  B. Insert the navigation device's support onto bracket (A) and cover (C). Fix utilizing the 4 screws (E) and the 4 washers (M) [3A].
Logged
Matboyslim
Guest
« Reply #10 on: April 02, 2015, 09:41:47 PM »

I called the dealer and he apologized for not including the fitting pack with the bike (very frustrating)
I think I've got everything I need now, thankyou all ever so much for your help and advice.
Logged
redeye
Doctor of Scooterology
*****

Karma: 28
Offline Offline

Location: Fannin County, Georgia
Posts: 2190

Thank You
-Given: 119
-Receive: 183



Email
« Reply #11 on: April 03, 2015, 04:26:29 AM »

Congratulations on getting this resolved. Please check in and hopefully post some pictures of the installation.
Logged
Maggie
Administrator
Doctor of Scooterology
*****

Karma: 168
Offline Offline

Location: St. Louis
Bikes Owned: The Fastest Ever Bet & Win 310cc ~ Tsunami 650cc ~ 09 TMax ~ 09 DN-01 ~ 17 Sypder RT-Limited
Posts: 15512

Thank You
-Given: 324
-Receive: 801


Let's Ride!!!!!!


« Reply #12 on: April 03, 2015, 01:40:04 PM »

+1
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!


Google visited last this page May 12, 2019, 05:39:33 PM